Return to the home page...

Go Back   Moyer Marine Atomic 4 Community - Home of the Afourians > Members List

RobbyBobby RobbyBobby is offline

Frequent Contributor

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. RobbyBobby
    12-03-2019 02:39 PM
    RobbyBobby
    Hello, my name is Robert and I am A Owner...

    I would like to ask for your help.

    I am new to Atomic Four. Become of the owner of one by inheritance of 1977 Catalina 30.
    This engine was working fine for first 3 nm, or 45 min. Next just stopped. No warning signs, no overheating. Just stopped. I got towing service and spent the rest on my journey relaxed. of course I want to fix it. No experience with gas engines, moderate with diesels. Here is what I am getting when attempting to start the engine. Video link
    https://youtu.be/Lw2EMC_4paw

    What do you think? Thank you very much for your thoughts and comments

    PS. I am dedicated to learning about my new power house, already purchased the Service and Overhaul Manual and.... decommissioned engine

About Me

  • About RobbyBobby
    Interests
    Sailing? Sailing!

Statistics

Total Posts
Visitor Messages
Total Thanks
General Information
  • Last Activity: 02-16-2021 05:32 PM
  • Join Date: 10-31-2019

Friends

Showing Friends 1 to 1 of 1

All times are GMT -4. The time now is 11:45 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.


Universal® is a registered trademark of Westerbeke Corporation

Copyright © 2004-2021 Moyer Marine Inc.

All Rights Reserved