Return to the home page...

Go Back   Moyer Marine Atomic 4 Community - Home of the Afourians > Discussion Topics > Troubleshooting

Reply
 
Thread Tools Display Modes
  #1   IP: 24.63.174.78
Old 07-03-2020, 08:00 PM
MightyMike MightyMike is offline
Senior Member
 
Join Date: Jun 2018
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Engine won't start

Hello,
I have not been able to start my motor this season. First I thought it was a fuel issue, because I left fuel in the carburetor over the winter. I was able to start the engine, but it would only run with the choke out and at idle. It would die as soon as throttle was increased.

Based on what Iíve read here, I removed and cleaned the carb and reinstalled. Itís the first time Iíve done that but it seemed to go back together well. I also changed the Racor filter and installed new plugs

It seems to me the cylinders are getting gas. When removing the plugs after trying to start they are wet and smell of gasoline.

Iíve moved on to the spark. I did the static coil check as shown in Donís video. The primary coil is showing 3.8 ohms and the secondary coil 10.71. I am assuming that is 1071 but at the wrong scale. There is a spare coil left by the previous owner and the results are similar on that one.
I have been unable to do a live spark test.

When I removed the distributor, which is quite a trick on this boat, I found the rotor contact dirty with carbon and what appears to be burns on each side of the contact in the plastic. The contact slides around a bit from side to side,

I am thinking I have found the problem, but donít want to order parts until I am sure. Should I replace just the rotor or also the electronic ignitor as well. The distributor cap seems fine except for the dinged up screws.

Thanks for your help.
Reply With Quote
  #2   IP: 155.186.124.219
Old 07-03-2020, 10:29 PM
Dave Neptune Dave Neptune is offline
Afourian MVP, Professor Emeritus
 
Join Date: Jan 2007
Location: Lake Arrowhead Ca.
Posts: 4,273
Thanks: 496
Thanked 543 Times in 377 Posts
Replace the cap & rotor as a set always. You will need to check for spark. Then look for why there is no spark in the wiring, voltages and such. Only after confirming the spark from the coil and still no spark to the plugs would it be time to look at the igniter itself. The trigger in the EI is what energizes the coil to send a spark through the distributor. The EI is the last check.

Dave Neptune
Reply With Quote
  #3   IP: 47.142.132.120
Old 07-04-2020, 01:01 AM
JOHN COOKSON JOHN COOKSON is offline
Afourian MVP, Professor Emeritus
 
Join Date: Nov 2008
Posts: 3,250
Thanks: 43
Thanked 656 Times in 491 Posts
Take voltage reading at coil + with the key on. Let's be sure there is power to the coil.

For sure replace any parts that don't look serviceable.

If you have questions about the parts send picture.

ex TRUE GRIT
Reply With Quote
  #4   IP: 24.53.89.131
Old 07-04-2020, 07:01 AM
Peter's Avatar
Peter Peter is online now
Senior Member
 
Join Date: Jul 2016
Location: Nova Scotia, Canada
Posts: 232
Thanks: 82
Thanked 96 Times in 71 Posts
Mike - the 10.71 in the secondary is 10.71 kOhms which is in the normal range.

I am a little confused by Daveís suggestion that ď Only after confirming the spark from the coil and still no spark to the plugs would it be time to look at the igniter itself. The trigger in the EI is what energizes the coil to send a spark through the distributor. The EI is the last check.Ē

I think if you get a nice spark from the coil the igniter is fine. Am I wrong?

And finally, to be perfectly clear, you were able to start the engine (although it would not run well) before the carb rebuild but not afterwards? If that is the case, why are you thinking that you now have an ignition problem? If the engine ran before the carb rebuild, does that not suggest that the ignition is ok? Definitely check for spark before ordering any parts.

Peter
Reply With Quote
  #5   IP: 24.152.132.140
Old 07-04-2020, 07:21 AM
ndutton's Avatar
ndutton ndutton is offline
Afourian MVP
 
Join Date: May 2009
Location: Torrance, CA
Posts: 8,992
Thanks: 162
Thanked 1,496 Times in 1,008 Posts
Quote:
Originally Posted by MightyMike View Post
When I removed the distributor . . . . .
Possible red flag here. Did you carefully mark the rotor position prior to removal? No movement of the crankshaft while the distributor was removed? Distributor reinstalled with the rotor and distributor housing positioned precisely as before? Unless all three of these protocols were carried out you are in for a start from scratch timing exercise.
__________________
Neil
1977 Catalina 30
San Pedro, California
prior boats 1987 Westsail 32, 1970 Catalina 22
Had my hands in a few others
Reply With Quote
The Following 2 Users Say Thank You to ndutton For This Useful Post:
Sam (07-04-2020), TimBSmith (09-08-2020)
  #6   IP: 155.186.124.219
Old 07-04-2020, 09:45 AM
Dave Neptune Dave Neptune is offline
Afourian MVP, Professor Emeritus
 
Join Date: Jan 2007
Location: Lake Arrowhead Ca.
Posts: 4,273
Thanks: 496
Thanked 543 Times in 377 Posts
The coil can be fine and throw a good spark when doing a coil check. If there is a good spark from the coil it does not mean that the igniter will trigger for a spark to be sent through the distributor to the proper plug.
Coil good and a bad igniter no spark to the plugs.
Igniter good and a bad coil also equals no spark to the plugs.

The igniter tells the coil to throw a spark when the rotor is pointing at the plug at the top of the compression stroke. Either one can be bad or very rarely both. these are separate parts in the same system.

Dave Neptune
Reply With Quote
The Following User Says Thank You to Dave Neptune For This Useful Post:
Sam (07-04-2020)
  #7   IP: 24.63.174.78
Old 07-04-2020, 11:44 AM
MightyMike MightyMike is offline
Senior Member
 
Join Date: Jun 2018
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Quote:
Originally Posted by JOHN COOKSON View Post
Take voltage reading at coil + with the key on. Let's be sure there is power to the coil.

For sure replace any parts that don't look serviceable.

If you have questions about the parts send picture.

ex TRUE GRIT
Here is a picture of the rotor.

I will test for power at the coil + when I go out to the boat later.

Thanks.
Attached Images
 

Last edited by MightyMike; 07-04-2020 at 11:46 AM.
Reply With Quote
  #8   IP: 24.63.174.78
Old 07-04-2020, 12:05 PM
MightyMike MightyMike is offline
Senior Member
 
Join Date: Jun 2018
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Quote:
Originally Posted by Peter View Post
Mike - the 10.71 in the secondary is 10.71 kOhms which is in the normal range.

And finally, to be perfectly clear, you were able to start the engine (although it would not run well) before the carb rebuild but not afterwards? If that is the case, why are you thinking that you now have an ignition problem? If the engine ran before the carb rebuild, does that not suggest that the ignition is ok? Definitely check for spark before ordering any parts.

Peter
Thanks for confirmation on the secondary coil values.

My troubleshooting methodology does seem suspect.
I left out some intermediate steps after cleaning of the carb. I also changed plugs and filtersbefore cleaning the carb. After reinstalling the carb I had to solve leaking at the sediment bowl and scavange tube. Once I solved for those I was clearly getting fuel in the cylinders and the moved onto the spark. Perhaps too soon.

I think it makes sense now to focus on the spark with all the good suggestions here before working back to the carb.

Thanks
Reply With Quote
  #9   IP: 24.63.174.78
Old 07-04-2020, 12:08 PM
MightyMike MightyMike is offline
Senior Member
 
Join Date: Jun 2018
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Quote:
Originally Posted by ndutton View Post
Possible red flag here. Did you carefully mark the rotor position prior to removal? No movement of the crankshaft while the distributor was removed? Distributor reinstalled with the rotor and distributor housing positioned precisely as before? Unless all three of these protocols were carried out you are in for a start from scratch timing exercise.
I did not turn over the engine with the distributor cap off. The rotor appeared to drop back in the very same position. Something new to worry about, I guess.
Reply With Quote
  #10   IP: 71.222.36.208
Old 07-04-2020, 02:37 PM
roadnsky's Avatar
roadnsky roadnsky is offline
Afourian MVP
 
Join Date: Dec 2008
Location: Lake Mead, NV
Posts: 3,000
Thanks: 22
Thanked 312 Times in 222 Posts
Quote:
Originally Posted by MightyMike View Post
I did not turn over the engine with the distributor cap off. The rotor appeared to drop back in the very same position. Something new to worry about, I guess.
Hi Mike-
I think to be clear, Neil is concerned that you removed the ENTIRE distributor as opposed to JUST the cover and rotor.
Can you clarify?
__________________
-Jerry

'Lone Ranger'

1978 RANGER 30
Reply With Quote
  #11   IP: 24.63.174.78
Old 07-05-2020, 08:21 AM
MightyMike MightyMike is offline
Senior Member
 
Join Date: Jun 2018
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Quote:
Originally Posted by roadnsky View Post
Hi Mike-
I think to be clear, Neil is concerned that you removed the ENTIRE distributor as opposed to JUST the cover and rotor.
Can you clarify?
yes, to confirm, I just removed the distributor cap, not the entire distributor.

Thanks.
Reply With Quote
  #12   IP: 47.142.132.120
Old 07-05-2020, 10:50 AM
JOHN COOKSON JOHN COOKSON is offline
Afourian MVP, Professor Emeritus
 
Join Date: Nov 2008
Posts: 3,250
Thanks: 43
Thanked 656 Times in 491 Posts
The rotor is scrap.
Quick question: Did you reconnect the spark plug wires in the correct firing order 1, 2, 4, 3?

ex TRUE GRIT
Reply With Quote
  #13   IP: 207.32.169.48
Old 07-05-2020, 02:36 PM
capnward's Avatar
capnward capnward is offline
Afourian MVP
 
Join Date: Aug 2012
Location: Deer Harbor WA
Posts: 265
Thanks: 20
Thanked 89 Times in 70 Posts
If you have to choke it to run, it is running too lean. Sounds like your distributor is ok, once you replace cap and rotor. EI is likely ok, if your spark is ok. Carb is probably ok as long as you reamed out the idle jet and other spots with a thin wire. If the idle jet was clogged, it wouldn't idle, but your problem is it won't accelerate. A clogged main jet would restrict fuel. Clogged ports in the side of the throttle throat will restrict acceleration.
Timing may be an issue. Sometimes turning the distributor a bit will enable it to start. Turning it clockwise retards the timing, and richens the mixture, from what I understand.
Did you reinstall the carb with new gaskets? If there is an air leak at the manifold gasket, the engine will run too lean, which could explain why it only runs with the choke closed. Also, make sure that your idle adjustment screw is one turn out from its seat, to begin with. Turning it out makes it run leaner. Always be sure of your firing order.
This forum never ceases to impress me, you are at the right place. Happy sailing!
Reply With Quote
The Following User Says Thank You to capnward For This Useful Post:
TimBSmith (09-08-2020)
  #14   IP: 24.63.174.78
Old 07-05-2020, 09:42 PM
MightyMike MightyMike is offline
Senior Member
 
Join Date: Jun 2018
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
We are back to the carb

I was able today to test out the coil.

With power on, I was reading 11.2 volts at coil +

With someone available to push the starter button we were
definitely getting a strong secondary pulse from the coil by holding the center coil wire near the block, as in Don's video. I only tested one plug, but we were getting a strong spark there as well.

We then tried to start the motor and we were able to start it after opening up the idle jet another full turn to 21/2 turns it ran for about 90 seconds with the choke open. The it just stopped. I then realized that I hadn't opened the fuel line.

We tried a few more times, but couldn't get it to kick over again.

I did not use a wire on either jet, but I did blast them both with carb cleaner when I had it apart.

I am going to play around with the idle settings tomorrow. Any other suggestions would be much appreciated.

By the way, I have a late model carb, but it does have an adjustable main jet.
I have experimented with different openings on that,from 2 to 4 turns out. I am not sure if that would impact starting, though.

Again,thanks for your continued support and advice.
Reply With Quote
  #15   IP: 155.186.124.219
Old 07-05-2020, 10:06 PM
Dave Neptune Dave Neptune is offline
Afourian MVP, Professor Emeritus
 
Join Date: Jan 2007
Location: Lake Arrowhead Ca.
Posts: 4,273
Thanks: 496
Thanked 543 Times in 377 Posts
The screw you are adjusting is for the "idle air" so open is lean and closed is rich.

Were you careful with the float setting?

Dave Neptune
Reply With Quote
The Following User Says Thank You to Dave Neptune For This Useful Post:
TimBSmith (09-08-2020)
  #16   IP: 24.63.174.78
Old 07-06-2020, 07:29 AM
MightyMike MightyMike is offline
Senior Member
 
Join Date: Jun 2018
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Quote:
Originally Posted by Dave Neptune View Post
The screw you are adjusting is for the "idle air" so open is lean and closed is rich.

Were you careful with the float setting?

Dave Neptune
Dave, I did not change the float settings. I didn't have a screwdriver wide enough to remove the float valve seat and I did not want to burr it up. The valve itself appeared clean as a whistle.
Reply With Quote
  #17   IP: 155.186.124.219
Old 07-06-2020, 10:44 AM
Dave Neptune Dave Neptune is offline
Afourian MVP, Professor Emeritus
 
Join Date: Jan 2007
Location: Lake Arrowhead Ca.
Posts: 4,273
Thanks: 496
Thanked 543 Times in 377 Posts
Exclamation

Mike, both the idle screw and the adj main jet start at about 1 1/2 turns off of the seat is where to start.

The idle screw adjust air so out is lean and in is rich!

The adj main jet is out for rich and in for lean! The adj-jet was designed to "tweak" the mix for fine tuning. The jet size is just a bit bigger than the stock one so the needle will influence the fuel flow, however once you are about 2 1/2 turns out the needle is pretty much done with it's ability to add more fuel. It is a sensitive adjustment.

Did you check to see if the float was at the correct setting?

When you were messing with the rotor did you check the centrifugal advance for smooth operation? Very important.

Dave Neptune
Reply With Quote
The Following User Says Thank You to Dave Neptune For This Useful Post:
TimBSmith (09-08-2020)
  #18   IP: 24.63.174.78
Old 07-06-2020, 02:23 PM
MightyMike MightyMike is offline
Senior Member
 
Join Date: Jun 2018
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Quote:
Originally Posted by Dave Neptune View Post
Mike, both the idle screw and the adj main jet start at about 1 1/2 turns off of the seat is where to start.

The idle screw adjust air so out is lean and in is rich!

The adj main jet is out for rich and in for lean! The adj-jet was designed to "tweak" the mix for fine tuning. The jet size is just a bit bigger than the stock one so the needle will influence the fuel flow, however once you are about 2 1/2 turns out the needle is pretty much done with it's ability to add more fuel. It is a sensitive adjustment.

Did you check to see if the float was at the correct setting?

When you were messing with the rotor did you check the centrifugal advance for smooth operation? Very important.

Dave Neptune
Hi, Dave,
I am going back down to the boat and will try jet settings as you suggest. I had read somewhere that the main jet should be at 3 turns out.

I am unfamiliar with the centrifugal advance, but will do some more reading.

I will also look into the float settings. I seem to be at an impasse here and am thinking I should pull the carb again.

Appreciate all your help.

Mike
Reply With Quote
  #19   IP: 165.225.38.188
Old 07-06-2020, 02:35 PM
Surcouf's Avatar
Surcouf Surcouf is offline
Senior Member
 
Join Date: May 2018
Posts: 244
Thanks: 167
Thanked 55 Times in 50 Posts
just to be 100% sure your carburetor / fuel supply is the issue, I would personally try to start again, confirm that the engine does not start, and try a second time with "start fluid spray", trying to maintain it running for 5-10 seconds. If the engine reacts positively to start pilot and does not without, you know it is very very unlikely that the issue lies with ignition, back-pressure, compression etc...

So many times I did some unnecessary "extra-work" by being non-systematic in my troubleshooting...
__________________
Surcouf
Almost There - Catalina 27 (1979)
Reply With Quote
The Following 2 Users Say Thank You to Surcouf For This Useful Post:
Peter (07-06-2020), TimBSmith (09-08-2020)
  #20   IP: 155.186.124.219
Old 07-06-2020, 03:21 PM
Dave Neptune Dave Neptune is offline
Afourian MVP, Professor Emeritus
 
Join Date: Jan 2007
Location: Lake Arrowhead Ca.
Posts: 4,273
Thanks: 496
Thanked 543 Times in 377 Posts
Mike, the rotor sits on top of the c-adv shaft. Just put the rotor on and give a twist, it should rotate just over 15* and spring back smoothly. If not some lubrication/cleaning may be in store for you. You can drop a bit of oil into the shaft housing when the rotor is removed, yep right down the hole. Won't lube the weights but can easily free up the shaft/counter-shaft assembly.

Not as tough as it sounds.

Dave Neptune
Reply With Quote
  #21   IP: 71.222.36.208
Old 07-06-2020, 08:34 PM
roadnsky's Avatar
roadnsky roadnsky is offline
Afourian MVP
 
Join Date: Dec 2008
Location: Lake Mead, NV
Posts: 3,000
Thanks: 22
Thanked 312 Times in 222 Posts
Quote:
Originally Posted by MightyMike View Post
I had read somewhere that the main jet should be at 3 turns out.
Mike-
Actually, I believe it is 1.5 turns out. (See attached instructions)

Quote:
I will also look into the float settings. I seem to be at an impasse here and am thinking I should pull the carb again.
Here are some float setting instructions I've kept in my 'word vault' (from Dave) ...

"When adjusting the float, err to the high side of the setting, which is a lower fuel level.

Hold the top half of the carb upside down with no gasket and the float installed, check the height with a scale (good ruler). The factory setting is 1 5/32" to the bottom of the float, which is on top and resting against the needle which is resting on the seat.
Two things of import here...
1-Be sure the bottom of the float is parallel with the body (this controls the closing position of the float accurately) of the carb, or as close as possible.
2-When tweaking the tabs use a pair of needle nose or duckbill pliers.
DO NOT PUSH, PULL OR BEND the tabs by holding the float itself. Only hold the brass tabs.
Now you can bend the larger portion that attaches to the float for the parallel adjustment and the little tab that rests on the seat for the height.
This can be a bit frustrating so go slow and easy. I suggest that if anything, you set the float a bit HIGH @ 1 3/16~1 5/32.
These adjustments are important to control the emulsion wells that mix air into the fuel to break it up! The factory adjustment specs are 1 5/32 +/_ 1/32" which is why you need it to be as parallel as possible. I run mine at 1 7/32 and like the way it performs."
Attached Images
 
__________________
-Jerry

'Lone Ranger'

1978 RANGER 30
Reply With Quote
The Following User Says Thank You to roadnsky For This Useful Post:
TimBSmith (09-08-2020)
  #22   IP: 24.63.174.78
Old 07-06-2020, 08:49 PM
MightyMike MightyMike is offline
Senior Member
 
Join Date: Jun 2018
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Quote:
Originally Posted by Dave Neptune View Post
Mike, the rotor sits on top of the c-adv shaft. Just put the rotor on and give a twist, it should rotate just over 15* and spring back smoothly. If not some lubrication/cleaning may be in store for you. You can drop a bit of oil into the shaft housing when the rotor is removed, yep right down the hole. Won't lube the weights but can easily free up the shaft/counter-shaft assembly.

Not as tough as it sounds.

Dave Neptune
thanks, Dave.
That does sound like something I can handle.
Reply With Quote
  #23   IP: 24.63.174.78
Old 07-09-2020, 10:39 AM
MightyMike MightyMike is offline
Senior Member
 
Join Date: Jun 2018
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
ordering rebuild kit

I have removed the carburetor again for another cleaning and a float adjustment based on what I have learned here.

I have spoken to the previous owner who tells me re did a full rebuild 7 or 8 years ago. I am thinking I will go with the more limited zenith kit since he has already changed out all the Jets etc. Based on this timeline, does anyone think I should do a full rebuild instead?

I have also mangled the scavange tube. I have ordered the replacement, but it is back ordered. I used a bit of jbweld to seal the fittings the last time, but I am thinking of replacing with caps temporarily while waiting for the back order.

I know they are 1/8 flair fittings, bit I don't know what the threaded side is. They seem larger than 1/8 inch.

Thanks
Reply With Quote
The Following User Says Thank You to MightyMike For This Useful Post:
TimBSmith (09-08-2020)
  #24   IP: 155.186.124.219
Old 07-09-2020, 11:01 AM
Dave Neptune Dave Neptune is offline
Afourian MVP, Professor Emeritus
 
Join Date: Jan 2007
Location: Lake Arrowhead Ca.
Posts: 4,273
Thanks: 496
Thanked 543 Times in 377 Posts
Mike, you can use either compression or flare fittings for 1/8 copper tubing. The port in the manifold and the carb are 1/8 NPT std fittings. Easy to fab on your own. The scavenge tube is a very important safety factor for an updraft marine carb!!!

Dave Neptune
Reply With Quote
The Following User Says Thank You to Dave Neptune For This Useful Post:
TimBSmith (09-08-2020)
  #25   IP: 207.32.169.48
Old 07-11-2020, 11:59 AM
capnward's Avatar
capnward capnward is offline
Afourian MVP
 
Join Date: Aug 2012
Location: Deer Harbor WA
Posts: 265
Thanks: 20
Thanked 89 Times in 70 Posts
A full rebuild of the carb, which is a replacement of the jets and other internal parts, is unnecessary as long as your existing parts are clean and installed correctly. But it won't hurt. With ethanol fuel the rubber tip of the float valve needle may degrade over time, in my opinion. The rebuild kit you get from Moyer has a small tapered wooden dowel which is used to dress the float valve seat. Should be no need to remove the seat.
Since you are taking the carb apart, I suggest you remove and inspect the tiny idle jet, although that is not causing your non-starting problem. File down a screwdriver so that it fits the slot in the jet snugly, and doesn't damage the threads in the carb. Once you have removed the jet, you can hold it up to the light and see any crud blocking it. It doesn't take much to mess up your idle. Then run a thin wire around in it to clear the crud. Spraying cleaner through it isn't enough. You wont see any blockage unless you remove it.
But I suspect your problem may be idle mixture adjustment. What you called the idle jet is actually the idle mixture adjustment needle valve. Page 4-3 of the Moyer manual shows this difference clearly. If you had it turned further out than 1 1/2 turns, it was adding too much air to the mixture, so it wouldn't start. Same effect as the choke not closing completely. Make sure you have a tight fit at the gasket where the carb joins the manifold. A new gasket helps with this.
Turn your adjustable main jet in all the way, then back it out 1 1/2 turns. This may clear any crud in it.
If you are one of us primitives with a mechanical fuel pump, you can use the hand bail to pressurize the fuel line all the way to the float valve before starting, and it will start sooner. If you have a fuel pressure gauge, you will see when the line has pressure. But you can feel it pressurize when the bail goes completely slack. You can hear the fuel filling the system as you pump it by hand. Then the sound goes away when it's full.
+1 on fixing the scavenge tube right away. You do not want it dripping into the bilge.
Keep up the good work. You are almost there. Let us know how it goes.

Last edited by capnward; 07-11-2020 at 12:06 PM. Reason: scavenge tube encouragement
Reply With Quote
The Following User Says Thank You to capnward For This Useful Post:
TimBSmith (09-08-2020)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
engine won't start sailr Troubleshooting 34 10-09-2018 12:25 PM
Engine won't start, 3 cylinders no compression Brent W Troubleshooting 27 07-15-2017 12:33 PM
Sudden very ragged running problem pdecker Troubleshooting 28 09-08-2015 07:46 PM
Engine very hard to start after cleaning distributor advance mechanism TomG Troubleshooting 10 02-11-2012 04:56 PM
Engine won't start, but I'm narrowing it down. Keir Hood Troubleshooting 3 06-23-2006 08:04 AM


All times are GMT -4. The time now is 06:30 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.


Universalģ is a registered trademark of Westerbeke Corporation

Copyright © 2004-2020 Moyer Marine Inc.

All Rights Reserved