Return to the home page...

Go Back   Moyer Marine Atomic 4 Community - Home of the Afourians > Search Forums

Showing results 1 to 5 of 5
Search took 0.00 seconds.
Search: Posts Made By: Dali007
Forum: Troubleshooting 09-13-2021, 11:44 PM
Replies: 3
Views: 320
Posted By Dali007
Dead battery?

Hi guys,

I have a weird issue that happened the last couple of times that I used my engine.
Run for 1 hour then quit, tried to start it and the battery was dead, switched to house battery and it...
Forum: Cooling System 06-20-2016, 11:19 PM
Replies: 12
Views: 2,723
Posted By Dali007
Thanks so much for your reply, someone at the...

Thanks so much for your reply, someone at the club said the same thing.

Would you know why is this happening all of a sudden? And also, how do I repair this?
Forum: Cooling System 06-20-2016, 11:05 PM
Replies: 12
Views: 2,723
Posted By Dali007
Exhaust Pipe Clicking

Hi all,
I have a Catalina 30 1980.

I had issues (up until now) where the engine would suddenly come to stop. We determined that it was a loose connector at the cockpit panel, after replacing many...
Forum: Troubleshooting 07-30-2014, 12:41 PM
Replies: 13
Views: 5,368
Posted By Dali007
Follow up

Thanks to Clucas, Dave and John!

We have not removed the distributor yet, thanks for the suggestion...

We have to check the orientation of the rotor...is it supposed to face away from the...
Forum: Troubleshooting 07-29-2014, 03:19 PM
Replies: 13
Views: 5,368
Posted By Dali007
Engine will not start

Hi all,

I hope that some of the atomic4neers can shed some light on the existing conundrum…

Here it is the etymology: We were motoring from Wilson, NY to Niagara-On-The-Lake, ON in a quite...
Showing results 1 to 5 of 5

 
Forum Jump

All times are GMT -4. The time now is 01:46 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.


Universal® is a registered trademark of Westerbeke Corporation

Copyright © 2004-2021 Moyer Marine Inc.

All Rights Reserved